Amp popped and started smoking......
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 31

Thread: Amp popped and started smoking......

  1. #1

    Default Amp popped and started smoking......

    so i realize i am getting no bass at all except for the stock speakers...and i check my setup, im running an MTX thunder 8302 amp, and a 10" sony xplod P5...so i stop, open the trunk thinkin maybe i knocked a wire loose or something throwin **** into my trunk and all are connected, so i check the fuses...both are popped, so i wait till i get home, replace the fuses and double check my ground wire...there was a little paint there, so i sanded it back to bare metal, replaced the fuses, and turn on my car, only to hear the sub pop cause of a dramatic vlume change (from kinda loud to nothing)and i see my amp start glowing fromthe inside and smoking...so i pull all the wires as fast as i can, bring the amp to the house (its fuggin cold) and dissect it...but nothing is showing up as burnt on the board...is the amp toast? or should i put a stronger than 30 amp fuse in it even tho thats what is calls for...and where do you guys have your ground wires? thanks in advance!!

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  2. Remove Advertisements
    Hyundai Elantra XD
    Advertisements
     

  3. #2
    Super Moderator hyunelan2 knows a lot about Elantras hyunelan2's Avatar
    Join Date
    May 2004
    Location
    Near Chicago, IL
    Posts
    15,186

    Default Re: Amp popped and started smoking......

    Don't put in a larger fuse. If the fuse popping is in the amp itself (opposed to the fuse on you 12v+ line) putting more power to the amp is not going to fix anything, but making a fire faster. Sounds like it's fryed to me.

    A good ground (sedan) is the bolt for the backseats that is located in the center of the back of the trunk. It can be seen when you fold the seats down.
    • Past: 2002 Elantra GLS (sold in 2010), 2003 Tiburon GT (Sold in 2014)
    • Present: 2004 Santa Fe GLS, 2004 Saab 9-3 Arc, 2010 Suzuki Equator Sport
    • Future: ????

  4. #3

    Default Re: Amp popped and started smoking......

    thats where i got mine grounded to....but i sanded it down to bare metal on the washer and the seat mount...

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  5. #4
    12V fanatic southpawboston has not yet proved knowledgeable southpawboston's Avatar
    Join Date
    May 2004
    Location
    Boston
    Posts
    1,713

    Default Re: Amp popped and started smoking......

    they don't call them xplod for nothin, haha.

    i think your xplod xploded. seriously. i think you probably melted the voice coil, which will essentially short circuit your amp. that's why the fuses blew. and as hyunelan said, never replace fuses with higher rated ones. they blew for a reason, and that was to protect the amp from a complete meltdown. as it is, it may have already done so.

    take an ohm-meter and test the resistance across the pos and neg terminals of the sub (with it diconnected from the amp). you should normally read anywhere from 2-4 ohms, depending on the ohm rating of the sub. if you read close to zero, it means the voice coil has definitely melted. if that's the case, it's toast... trash it.

    just remember that ANYTIME an amp fuse blows, it may mean that the speaker has melted and shortcircuited.

    now, the reason this happened? that is a topic for a different discussion.
    Last edited by southpawboston; 03-07-2006 at 01:24 PM.
    2006 Mazda3 S Touring 5-dr

  6. #5
    1997 Hyundai Elantra BogiesHyundai has not yet proved knowledgeable BogiesHyundai's Avatar
    Join Date
    Feb 2006
    Location
    Indiana
    Posts
    135

    Default Re: Amp popped and started smoking......

    was this on your way home from my house?

  7. #6
    NICE05XD importdriver05 has not yet proved knowledgeable importdriver05's Avatar
    Join Date
    May 2005
    Location
    Asheville,NC
    Posts
    371

    Default Re: Amp popped and started smoking......

    oh no i hope that mystery smoke didnt come out if it did then it maybe fried, wish you the best and hope u get it fixed.
    2005 moonlit blue elantra,sony xplod h.u., debadged, hks muffler, sylvania silverstar headlights
    I cant drive 55 !

  8. #7

    Default Re: Amp popped and started smoking......

    yeah...so an update on the amp situation, i tried to replace the fuses and they try to arc when i connect them, i had the amp apart but could not see any damages to the capacitors, resistors, or circuitry itself, and i pulled the sub out of the boox and it looked good as well...right now i got a bid in for the same amp that i have now cuz i love it...but if anyone close wants to help out, lemme know...

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  9. #8
    Senior Member subvibe99 has not yet proved knowledgeable
    Join Date
    Jul 2004
    Location
    Massachusetts
    Posts
    553

    Default Re: Amp popped and started smoking......

    you should sell the blown amp to a punk kid trying to hook up his cheap *** civic.

    you should sell the blown amp to a punk kid trying to hook up his cheap *** civic.

  10. #9
    1997 Hyundai Elantra BogiesHyundai has not yet proved knowledgeable BogiesHyundai's Avatar
    Join Date
    Feb 2006
    Location
    Indiana
    Posts
    135

    Default Re: Amp popped and started smoking......

    ..................................

  11. #10

    Default Re: Amp popped and started smoking......

    lol...i COULD put it on ebay for a starting bid of $20 untested...**thinking**

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  12. #11
    Junior Member Biff has not yet proved knowledgeable
    Join Date
    Feb 2005
    Location
    Bloomington, IN
    Posts
    200

    Default Re: Amp popped and started smoking......

    You made sure it was the amp and not the sub right? I was puzzled when I saw this thread today. I sold that sub to you practically new. Anyways, I hope it goes well for you. I looked up the specs on that amp and it is a perfect union/marriage for that sub. How did it sound when it was all working? Because you were feeding it about 100 more watts of power than I was.

  13. #12

    Default Re: Amp popped and started smoking......

    it sounded great...better than the 2 12's hooked up to it proir...the sub looks good, i pulled it out of the box and made sure the wires were right and even put new wires on it, so im thinkin its something goin on with the amp...i got one im watching on ebay and when it gets to about 2 minutes im gonna pounce on it and put the other up as parts or somethin...

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  14. #13
    circuit track whore 2loud2k2xd has not yet proved knowledgeable 2loud2k2xd's Avatar
    Join Date
    Oct 2004
    Location
    detroit
    Posts
    3,820

    Default Re: Amp popped and started smoking......

    try this, this is a way to see if the sub is fried. get a 9volt battery..the small rectangle ones that you used to touch your tounge to and get a buzzing sensation. lol
    anyway, hook up the + from the sub to the + of the battery, then the - of the sub to the - of the battery, it should humm. if not its blown also. and just because the amp does not smell, doesnt mean its not blown. i fried my deck, sub amp, component amp, and all 6 channels of rca wires (dont ask). i fried the rca imputs on both amps cause of a voltage spike.

    and listen to southpaw, and hyun. do not put a larger fuse in, or your asking for a fire.
    click here for K-sport coilover deal
    http://www.elantraxd.com/forums/showthread.php?t=14992

  15. #14

    Default Re: Amp popped and started smoking......

    i wasnt gonna try a larger fuse...i found that out the hard way with the mustang i had and the foglight wiring caught fire... ill try thr battery when i get home as i am still at work and dont have a battery here...i appreciate all the help guys, and im hoping to fix this soon

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  16. #15
    circuit track whore 2loud2k2xd has not yet proved knowledgeable 2loud2k2xd's Avatar
    Join Date
    Oct 2004
    Location
    detroit
    Posts
    3,820

    Default Re: Amp popped and started smoking......

    dont forget, its the small 9volt battery im talking about. not the big one for some flashlights, but the ones found in old school tv remotes.

    ps.. dont forget to touch your tounge to the battery posts. bring back some memories when you were a kid...... or was it just me who did it? lol
    click here for K-sport coilover deal
    http://www.elantraxd.com/forums/showthread.php?t=14992

  17. #16
    12V fanatic southpawboston has not yet proved knowledgeable southpawboston's Avatar
    Join Date
    May 2004
    Location
    Boston
    Posts
    1,713

    Default Re: Amp popped and started smoking......

    try 2loud's battery test, that's good. but definitely try the ohm meter test that i mentioned above. you're coming to conclusions without doing any testing. how can you tell your sub isn't blown by just looking at it?
    2006 Mazda3 S Touring 5-dr

  18. #17
    Workin' robs02elantra has not yet proved knowledgeable robs02elantra's Avatar
    Join Date
    Aug 2005
    Location
    Ottawa, Ontario
    Posts
    3,150

    Default Re: Amp popped and started smoking......

    Quote Originally Posted by 2loud2k2xd
    ps.. dont forget to touch your tounge to the battery posts. bring back some memories when you were a kid...... or was it just me who did it? lol
    Nope, did it all the time as well. Never learned my lesson.

    I was changing one at work the other day from a smoke detector, and I was still very tempted, even knowing exactly what would happen.

  19. #18

    Default Re: Amp popped and started smoking......

    so i did the 9volt test...the sub made a crinkly sound...not a hum... and i replaced the fuses in the amp and it still smokes and the LED for the power doesnt come on anymore (im not sure if it has to have subs hooked to it or not for it to come on) so i think that both took a **** on me...but when i had power to the amp the fuses didnt blow...so i dont know if it smoking means its fried...and the sub went with it...or if it was the other way around, but im not too happy now cause it sounded so good, and the last time it was hittin was when i was at bogies house...and on the way home from there at white castles...other than that the head unit was turned down to like 2 cause i was on the phone with scott most of the way home...what could have caused this to just happen like it did...this is the first time ive had any subs or amps so this is a first time thing for me

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  20. #19

    Default Re: Amp popped and started smoking......

    so just out of a hunch, i hook my sub up to my little radio in my shed, it still plays, but the louder i'd turn the radio up, the more and more it sounds like the seaker is popped...and with the 9volt batt...im not even sure how that would really work, because the sub picks up audio waves, not voltage...

    http://www.elantraxd.com/cotm/april07.php

    "President Obama to increase the tax on aspirin by 40%... due to the fact it is white, and it works."


  21. #20
    Junior Member chaos GT has not yet proved knowledgeable
    Join Date
    Aug 2004
    Location
    PA
    Posts
    141

    Default Re: Amp popped and started smoking......

    audio waves really are just ac voltages though. the 9v battery is dc and so what happens when hooked up to a speaker is that the cone should push all the way out (or suck in if you hook it up backwards) and stay there until you remove the battery. i've done this on a few different subs and it's very clear whether or not its working. the cone moves from it's resting position and there's usually a clicking noise or something similar.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts