Anyone ever have code P0441 - EVAP Incorrect Purge Flow?
+ Reply to Thread
Results 1 to 11 of 11

Thread: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

  1. #1

    Question Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    My CEL came on 2 days ago for the first time in over 3 years and over 100K miles. I got P0441 - EVAP Emissions System Incorrect Purge Flow. It came on 1 day and about 169 miles after filling up the tank. So I checked the gas cap and cleared the light and it came back on after about 20 miles. Anyone ever get this code and find a fix?

    I am thinking I might have bad gas, so I am gonna run through this tank and fill up again and see if it goes off by itself before I really get into diagnosing this.
    -ASE Certified Automotive Technician


    Check out my 02 GLS:


  2. Remove Advertisements
    Hyundai Elantra XD
    Advertisements
     

  3. #2
    Veni, Vidi, Velcro Munky has information that can be trusted Munky has information that can be trusted Munky's Avatar
    Join Date
    May 2006
    Location
    Noblesville, IN
    Posts
    10,970

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Try seafoam as well.


    Veni, Vidi, Velcro : I came, I saw, I stuck around

  4. #3
    Senior Douche BobMs_wht2k2 knows a lot about Elantras BobMs_wht2k2's Avatar
    Join Date
    May 2004
    Location
    Indiana
    Posts
    11,232

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Purge valve probably took a dump. It was a VERY common problem on the J2's IIRC.

  5. #4

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Quote Originally Posted by BobMs_wht2k2 View Post
    Purge valve probably took a dump. It was a VERY common problem on the J2's IIRC.
    That's what's I am guessing as well. But I wanna get rid of this gas first to make sure it's not screwing up anything or to see if it's just a conicidence that it came on the day after a fill up.
    Last edited by DJ Hellfire; 07-11-2007 at 05:40 PM.
    -ASE Certified Automotive Technician


    Check out my 02 GLS:


  6. #5
    Senior Douche BobMs_wht2k2 knows a lot about Elantras BobMs_wht2k2's Avatar
    Join Date
    May 2004
    Location
    Indiana
    Posts
    11,232

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Purely coinkydink I think.

  7. #6
    Senior Member 2000 elantra has not yet proved knowledgeable 2000 elantra's Avatar
    Join Date
    Jun 2006
    Location
    delware,ohio
    Posts
    713

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    i'm going thew this right now.I changed the gas cap today for a brand new one.Still getting the light.Need a vaccum gauge and handheld pump to check the 2 way valve and the canister purge valve.Checked to see if the the hose was clogged but it wasn't so time to get more tools and start checking vaccume pressure.
    "life is like a box of chocolate you never know what honda you'll beat."

  8. #7

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Quote Originally Posted by 2000 elantra View Post
    i'm going thew this right now.I changed the gas cap today for a brand new one.Still getting the light.Need a vaccum gauge and handheld pump to check the 2 way valve and the canister purge valve.Checked to see if the the hose was clogged but it wasn't so time to get more tools and start checking vaccume pressure.
    This is what I have to go off of...and I'll share :
    http://i19.photobucket.com/albums/b1.../P0441Diag.jpg


    So, I vacuum tested the PSV and it's stuck closed. When I apply power and ground to the terminals it barely "pops" and it holds vacuum whether it's energized or not. It's FUBAR. Tried beating it on the ground a bit and it won't open.
    Last edited by DJ Hellfire; 07-12-2007 at 05:46 PM. Reason: Automerged Doublepost
    -ASE Certified Automotive Technician


    Check out my 02 GLS:


  9. #8
    Senior Member 2000 elantra has not yet proved knowledgeable 2000 elantra's Avatar
    Join Date
    Jun 2006
    Location
    delware,ohio
    Posts
    713

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    when I get the chance ill write up what HAYNES book says.Its kinda funny that yours is stuck close and mine is stuck open.
    "life is like a box of chocolate you never know what honda you'll beat."

  10. #9

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Quote Originally Posted by 2000 elantra View Post
    when I get the chance ill write up what HAYNES book says.Its kinda funny that yours is stuck close and mine is stuck open.
    So what code are you getting, excessive flow or still incorrect flow like mine? Also, webtech has a procedure as well.
    Last edited by DJ Hellfire; 07-13-2007 at 09:27 PM.
    -ASE Certified Automotive Technician


    Check out my 02 GLS:


  11. #10
    Senior Member 2000 elantra has not yet proved knowledgeable 2000 elantra's Avatar
    Join Date
    Jun 2006
    Location
    delware,ohio
    Posts
    713

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    mine is p0441 Evap emissions control system,purge valve stuck open. this sucks.It comes on every 20 minutes.the dealer is the only place to get a new one around here.Dont you work at a hyundia dealership.
    "life is like a box of chocolate you never know what honda you'll beat."

  12. #11

    Default Re: Anyone ever have code P0441 - EVAP Incorrect Purge Flow?

    Quote Originally Posted by 2000 elantra View Post
    Dont you work at a hyundia dealership.

    No, I ordered mine from an online OEM parts dealer for $18, $28 total after shipping. My closest local dealer, which is like 15-20 miles from my house, wants $40 plus tax for it. It's the same price for a 2000: http://www.worldpartsexpress.com/par...=1&catalogid=2.
    -ASE Certified Automotive Technician


    Check out my 02 GLS:


+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts