No heat while at idle
+ Reply to Thread
Results 1 to 12 of 12

Thread: No heat while at idle

  1. #1
    Newbie jasonburrell has not yet proved knowledgeable
    Join Date
    Dec 2010
    Location
    Redmond, WA
    Posts
    1

    Default No heat while at idle

    My car does not produce heat while at idle, if I shift into nutural and rev it to 1500rpm the heat is fine, also the heat is fine while driving. I have read some of the forums and found that the issue might be due to low coolant or a water pump issue, is there any way to tell which one is the problem?

  2. Remove Advertisements
    Hyundai Elantra XD
    Advertisements
     

  3. #2
    Junior Member ChrisQ05GT has not yet proved knowledgeable ChrisQ05GT's Avatar
    Join Date
    Dec 2010
    Location
    New York
    Posts
    109

    Default Re: No heat while at idle

    You are either low on coolant, or your thermostat is stuck open.

  4. #3
    Senior Member judys01GT has not yet proved knowledgeable judys01GT's Avatar
    Join Date
    Nov 2007
    Location
    new york
    Posts
    646

    Default Re: No heat while at idle

    Quote Originally Posted by ChrisQ05GT View Post
    You are either low on coolant, or your thermostat is stuck open.
    low coolant

  5. #4

    Default Re: No heat while at idle

    could be neither. after i added weather stripping to the back of the hood, where it comes with some from the factory, i seem to have fixed the problem.

    seems like all the cold freezing air getting into the engine bay down the firewall was causing the heater core lines to get quite cold, i no longer seem to have the issue of cold air at idle.

  6. #5
    Super Moderator Cypher knows a lot about Elantras Cypher's Avatar
    Join Date
    Jun 2005
    Location
    Eastern Shore, MD
    Posts
    12,634

    Default Re: No heat while at idle

    Logically that doesn't really make much sense Pete. The cold air isn't going to be enough to cool down the ~190* coolant going through the heater core.
    2002 Hyundai Elantra: Sold
    1991 Nissan 240sx Hatch SR Swapped: Sold
    1992 Toyota MR2: Sold
    1991 Nissan 240sx Coupe: Future KA-T
    1999 Hyundai Tiburon: Daily Driver

  7. #6

    Default Re: No heat while at idle

    i dont get it either man. why has this happened in any past winters? i dont know how to explain it.

    but i bought some weather stripping from advance, n put it where the oem would b under the back of the hood. and i seem to be getting normal heat at idle again.

    dont know man. im just sharing what ive done.

  8. #7
    Newbie 2005elantrahyun has not yet proved knowledgeable
    Join Date
    Jan 2011
    Location
    Amherst Ohio
    Posts
    1

    Default Re: No heat while at idle

    I have a 2005 Elantra that is doing the same thing. It just started only producing heat when the engine is above idle. Has anyone figured this out? I would appreciate any help on this. Thanks.

  9. #8

    Default Re: No heat while at idle

    This is almost definitely due to a problem with the heater core not getting enough or any coolant flow through it. You could have a clogged heater core, air pocket, or not enough coolant. Since heater cores are designed to be bypassed if they clog the engine will still run at a normal temperature but you won't have any heat.

    Try disconnecting the heater core lines and flushing water through it. Your car is only a 2005 so I can't see how the core could be clogged but anything is possible.

    Did anyone add Dexcool or any type of "non green" coolant to the system?

  10. #9
    Newbie dano has not yet proved knowledgeable dano's Avatar
    Join Date
    Nov 2013
    Location
    Saint Paul, MN
    Posts
    6

    Default Re: No heat while at idle

    I'm kinda new at this so I hope it's ok to post to an old thread and hope someone will read this.
    I've had this same problem lately. Replaced the thermostat today and not sure the problem is fixed. My wife mostly uses the car and I'm sure she will let me know tomorrow. Is it possible my heater core is clogged? I don't have any coolant leaking. It's a 2002 Elantra with 200K miles.. Thanks for any input.
    Dan O

  11. #10
    Junior Member Finn1200 has not yet proved knowledgeable Finn1200's Avatar
    Join Date
    May 2013
    Location
    S.E. Pa
    Posts
    146

    Default Re: No heat while at idle

    Is the temp gauge reading that the engine is getting hot?
    If not, then check your coolant level.
    If it is, check your return hose from the heater core to see if it is hot.
    If its not (or at least warm) then you might have a clogged heater core.

  12. #11
    turbo envy only1db has picked up a wrench only1db's Avatar
    Join Date
    May 2004
    Location
    Tannersville, PA
    Posts
    12,878

    Default Re: No heat while at idle

    stuck open is not its natural position...usually it gets stuck closed.

    just make sure all of the bubbles are out of the system...i had one some residual bubbles and i had no heat at idle till i "burped" the system again.


    Silver Certified Tech turned Sonographer! and blogger?? check it out!!

    http://allthingshyundai.blogspot.com/

    Veloster Turbo is in the future....

  13. #12

    Default Re: No heat while at idle

    i have a 2002 elantra with no heat,i change the head gasket today and refill the system,run the at idle for 45 min. still cold air.why is lower rad hose and one heater core hose are cold.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts