Need some help [Archive] - Hyundai Elantra Forum

: Need some help



JacksonJ
10-13-2004, 10:47 PM
About a week ago, my wipers stopped working all together. Since moving into my new apartment, this is the first chance I got to look at them.

It seems that one of the pivots is ceased up. I'm letting some Duralube soak into it. But is there some kind of grease that I should apply as well? and if so, which kind?

And incase your wondering, I have Rain-X on my windshield but with the Canadian Winter comming up, I want to get this fixed.

Edit - Added pics to show what part is wrong, as I said, this thing is ceased, the one moves freely while this one won't move at all. I have 140,000 Kms. I broke the warrenty over a year ago. I'll have to go to a junk yard to fix it. One good thing is that it's the passenger side that is ceased, I could always put it back on with only the drivers side working for now.

2004ElantraGLS
10-13-2004, 10:57 PM
I've never had this problem with a Hyundai, but in other cars it was always the wiper motor. If the duralube doesn't take care of the problem, I doubt any kind of grease will help. I also use RainX, and I've replaced the stock POS wipers with double-blade units.

If your car is still under Warrenty, have the Dealer take care of it.

Axel

JacksonJ
10-14-2004, 12:58 AM
Well, I got it to start moving after using a lot of duralube and using the wiper arm as leverage. It was just starting to loosen off then the wiper arm snapped.

So, I'll be going to a junk yard tomorrow to pick up both pieces, the pivot is still sticking enough to warrent getting a whole new assembly.

XTRAWLD
10-15-2004, 10:25 AM
Oh...this happened to mine.......the wipers were moving so slow, I'm like WTF...I took it in and they replaced the pivoting joint because it was busted. They said it looked like a part that was on a car for 10 years and was very close to just breaking altogether.