[XD2] Missing part of header? Wrong part entirely?
+ Reply to Thread
Results 1 to 7 of 7

Thread: Missing part of header? Wrong part entirely?

  1. #1
    Newbie crowquill has not yet proved knowledgeable crowquill's Avatar
    Join Date
    Dec 2005
    Location
    Evansville, Indiana
    Posts
    16

    Default Missing part of header? Wrong part entirely?

    Blew a head gasket last year, but I've loved my XD2 and wasn't ready to part with it yet. I had free time but I'd never done this before. Ended up buying replacement header from Advance and after fighting with poorly drilled and/or tapped holes I've got it mostly together. Wasn't until today I actually put the cover on and realized there was a "hole".

    Did I get the wrong version of the header? Did I forget to swap something over from the old one? What the hell is the name of that part if I need a replacement? Most importantly, can I make this thing work?
    Attached Images

  2. Remove Advertisements
    Hyundai Elantra XD
    Advertisements

  3. #2
    Poster God mkjh has information that can be trusted mkjh has information that can be trusted mkjh's Avatar
    Join Date
    May 2014
    Location
    Los Alamitos
    Posts
    1,830

    Default Re: Missing part of header? Wrong part entirely?

    You are missing the half moons. They install right in that spot with silicone. You absolutely need that part. I might actually have a few extra brand new you can have. I'll take a look a little later today and let you know. I just replaced the gasket a few months ago and they sent the half moons to me when I didn't need them. DO NOT run the car without them.

  4. #3
    Newbie crowquill has not yet proved knowledgeable crowquill's Avatar
    Join Date
    Dec 2005
    Location
    Evansville, Indiana
    Posts
    16

    Default Re: Missing part of header? Wrong part entirely?

    That would be amazing if you have any spares.

    I definitely won't try starting it until that's in. I've already seen the mess that a leaking valve cover gasket can make. No way I'd try running it with a hole in the side.

    Generally I'm the type of newb who is overly cautious. Can't believe I overlooked this difference between the two.

    Sent from my XT1650 using Tapatalk

  5. Remove Advertisements
    Hyundai Elantra XD
    Advertisements

  6. #4
    Poster God mkjh has information that can be trusted mkjh has information that can be trusted mkjh's Avatar
    Join Date
    May 2014
    Location
    Los Alamitos
    Posts
    1,830

    Default Re: Missing part of header? Wrong part entirely?

    Okay I'll check and let you know a little later today. There should also be a half moon on the other side of the gasket so you will need two. Check to make sure that you will need two.

  7. #5
    Newbie crowquill has not yet proved knowledgeable crowquill's Avatar
    Join Date
    Dec 2005
    Location
    Evansville, Indiana
    Posts
    16

    Default Re: Missing part of header? Wrong part entirely?

    I'm assuming I do. Are you talking about 2 that fit into that cutout in the head or one in the cutout and one in the cover. Cutout is empty, cover is original and intact.

    Sent from my XT1650 using Tapatalk

  8. #6
    Newbie crowquill has not yet proved knowledgeable crowquill's Avatar
    Join Date
    Dec 2005
    Location
    Evansville, Indiana
    Posts
    16

    Default Re: Missing part of header? Wrong part entirely?

    While I finished reassembling the rest of the engine yesterday I realized there are actually 3 missing plugs. Didn't realize there was one on the passenger side behind the timing belt sprocket.

    Being that I needed 3 and I'd found a decent price on eBay I pulled the trigger on those. Thanks MKJH for both the assistance and the parts offer.

    Sent from my XT1650 using Tapatalk

  9. #7
    Poster God mkjh has information that can be trusted mkjh has information that can be trusted mkjh's Avatar
    Join Date
    May 2014
    Location
    Los Alamitos
    Posts
    1,830

    Default Re: Missing part of header? Wrong part entirely?

    Okay no problem. It took me awhile to find them but I did find them. I forgot there were three. I have a sealed bag of three. Glad you were able to find them on ebay though. Anyways, make sure to use silicone when you install them.
    Last edited by mkjh; 05-26-2019 at 12:45 PM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts