Hyundai Elantra Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a brand new 2011 Elantra GLS. I just want to know if it is normal for this 1.8 CCVT engine to sound like a diesel engine, even though it is a petrol engine. Diesel Engines normally create rattling sounds, which i can also hear from my 1.8 2011 Elantra Engine. I want to know some personal views and experiences about your Elantra 2011 GLS. Also, maybe some issues if there is any. Thanks!
 

·
7 psi tunned by poweraxel
Joined
·
3,203 Posts
The noise you hear on a diesel engine comes from the injectors, they are very noisy with direct injection.

I haven't heard what a 2011 elantra engine sounds like but one thing is for sure, "the 2011 Elantra does NOT have Direct Injection" and you should probably get it checked out by your local dealer just to make sure,
I would start by checking the oil level first, usually an engine with very low oil will make a rattling sound and that is no good. If its low top it off or get the oil changed if its due.
 

·
turbo envy
Joined
·
12,884 Posts
yep thats normal, you're just hearing the DI at work.

enjoy your stay!
um what??? DI is not available on the MD/UD as of yet. i would go and get it looked at....how many miles do you have on it? i think they use mechanical lash adjusters...was the car sitting for awhile? does the rattle go away after idling/ driving for a little bit?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
only1db,

I already asked my dealer for other Elantras, so that I could listen to its engines. I drove almost 550km(Here in Asia we use km/L) or 350miles. I usually hear the rattling sound during the very first start of the engine during the day. But, I'm still waiting until the break-in period finishes. I hope after this period I won't be able to hear this rattling sound again.
 

·
7 psi tunned by poweraxel
Joined
·
3,203 Posts
Interesting, my 01 XD rattles only at cold start, after a min it quiets down. i got my car with 60k miles and was told this was normal, i got 140k miles now and even tough it still does that noise at cold start it has never given me any issues.
sounds like you have a similar thing going on on your MD.
 
1 - 8 of 8 Posts
Top