Hyundai Elantra Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey All...I posted about this issue a few times, but wanted to post because I noticed a few things now that I hadn't noticed before.

The problem I was having was that I would be driving, and I'd press the gas, but the car wouldn't accelerate. RPMs would go up, but car wouldn't move.

I noticed that it happens on trips that are more than 40 miles in one direction. I commute 25 miles each way to work and never had the problem. It also tends to happen one time going in each direction.

On the way to Pennsyvlania, I noticed when I pressed the gas, it was almost as though I was pressing the brake. It seemed as though the car had "switched" the pedals, accept the brake just broke as opposed to helping with acceleration. But when I press the gas, it seems to sort of shut down the car without actually doing so, like it seems the car is going to just completely stop.

Anything anyone can offer is GREATLY appreciated. I've now had two mechanics look at it and neither one can figure it out. My girlfriend's coworker says she had the same exact problem, and surely enough, she can't remember what it was that the dealership fixed...trying to avoid the dealership as I don't want them to manufacture a problem to solve that costs me money and gets me no further. Thank you!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Hey, I live in Rahway, I work in Fairfield. Whatever you can do, if anything, is greatly appreciated. Let me know. Thank you either way.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top