Hyundai Elantra Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I just changed the fuel pump and the fuel filter on my elantra and replaced the fuel regulator. but I can not get any fuel to the engine. I have tried blowing out fuel lines. opened gas tank to see if I can represureize the fuel line. but get nothing. help..... please... I also forgot to unpresurise the line when I took it off..
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
I am pretty sure I did. I put it back just as I took it out. the engine will turn over, but idk what I could be doing to keep it from starting. I know it has to be simple I am sure, but clueless here, ty

i also know fuel pump is working I here it, running, I also changed out the purge valve...

ty
 

·
im still a junior member?
Joined
·
261 Posts
There is a rubber nipple sleeve under the fuel filter that goes on the pump outlet. LOTS of people miss that one. Mine tore on reinstall, just an idea
 

·
Registered
Joined
·
2,495 Posts
I replaced my pump about a year ago did it my self followed the instructions on the diy fuel filter & once I was putting everything together I made sure I had everything back how it was & turned on I would double check your pump assembly for anything missing or make sure its on correct just my 2 cents
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
thanks I did miss the o ring. I put it on. and still don't have no gas going to engine. another impute would be very helpful. you were talking about the one on the fuel pump right? I am just at ends wit with this thing. seemed pretty straight forward to fix. I know it has to be something simple. idk if this would make a deference I did not let the car run for a few mins to get the fuel out of the lines . just really frustrated at this point. I will accept any help or ideas.
ty
 

·
im still a junior member?
Joined
·
261 Posts
Im thinking an o-ring either has a tear or not seated right. The filter on these cars are tricky and have given a few people headaches. Me included...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
well I pulled the pump back out once again... cked the fittings and everything looked good. and so when I pulled the casing that goes arounf the fuel pump. guessing this is the actual fuel filter? and their was some gas in it I swished it around some and black gritty stuff cam pouring out. I said wow that's nasty. I had to order a new filter... do u think this was my problem on the gas not coming out?
 
1 - 14 of 14 Posts
Top