Hyundai Elantra Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter #1
Well I was wiring in a switch to turn my fogs on and off. I got that working and was trying to hook up the light inside the rocker switch I got. I was planning on using the dimmer switch to get power to it, but some how or the other a wire touched the wrong place, I heard a faint pop and poof no more lights on my gauge. The lights around the gauge work, like the HB light srs airbag,etc. just the actual gauges and odo. dont light up. I checked all the fuses to the left of the wheel that I thought might have blown, and I even looked at the fuses in the engine, but all seemed fine. Anybody know what is up????? :confused:
 

·
Registered
Joined
·
851 Posts
It's a fuse, you sure you completely checked the fuse panels? If so, then just wait for Southpawboston or Sed or someone who has the elctrical knowledge to tell you where to find the offending fuse.
 

·
Registered
Joined
·
880 Posts
i'm with steve...gotta be the fuse...i had a similar thing happen when i was doing the LED conversion. i can't remember which fuse it was though, sorry. i think it was something random like tail lights or blinker or something.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #4
yevRPS said:
i'm with steve...gotta be the fuse...i had a similar thing happen when i was doing the LED conversion. i can't remember which fuse it was though, sorry. i think it was something random like tail lights or blinker or something.
Wow, who woulda thought the gauge lighting was with the tail light fuse?? Oh well, gotta fresh new fuse in there now. Thanks for the quick responses guys. :D
 

·
KDM to JDM.
Joined
·
6,437 Posts
My cluster LEDs dont work either! I touched the back of my cluster to the metal chasis when my dash was off...and POP! first my gas LEDs went out, then 5 minutes later the rest went. To me that was proof enough that it wasnt a fuse....or maybe it is a fuse.
Which number is the fuse that has to be replaced to get the LEDs back? And what type is it, 10, 15, 20...30?
 

·
Registered
Joined
·
212 Posts
Discussion Starter #6
Not sure about the information lights like high beam, airbag, etc., but the lights that lights up the gauges like speed, odo, tach are connected to the tail light fuse. I believe there is a specific fuse for the information lights, I think its listed something like "cluster" or something like that I beleive its on the second row down closest to the left side.If you look at the back of the little storage unit that you pull out toi access the fuses it shows all the fuse locations.
 

·
Registered
Joined
·
212 Posts
Discussion Starter #9
If you DIY and get the LEDs from radioshack it will be about 1.50 per LED...
If you DIY and get the LEDs from internet it will be about .50 per LED...
If you take it to the dealer they will order a whole new unti and charge you out the @#%...

Hope this helps in your decision :D
 
1 - 10 of 10 Posts
Top