Hyundai Elantra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
OK. Noticed yesterday air condit was warming..... Looked and engine temp was high. Saw cople drips going under car, assumed it was coming from the AC-
Put some coolant in res.... took half a jug...
I replaced the T Stat and gasket this aft-
1- Replacement T stat looked different! It fit tho, so i used it (new is rounded face out/ old is pointed) Does the GL have a dif T stat? Parts store didnt ask.
That Did NOT stop the overheating so I looked at the dripping under car- Its coolant.
Could it be the H2O pump? And i fried a lower gasket and got the leak? Hardly driven hot.... but possible?
I dont see a leak at the top of the radiator or at any connections.
has anyone experienced this?
Please help
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Update- Resevoir has coolant... Drove @ 3 miles. There is a dripping leak of coolant for sure- cant tell where. Now will only blow cold- still overheating.
Im gonna change radiator tomorrow unless anyone has any better advice.....
 

·
Registered
Joined
·
988 Posts
All thermostats are the same. I think you installed thermostat wrong way. The pointed side should face outward and the rounded side is installed directly to the intake manifold. You have to use good gasket also. Otherwise, coolant may leak. Read my other articles regarding this matter. I had same problem as you have. Check the radiator also. You might need a new radiator for '03.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Yeah...... I know- It was completely diff- The pointed side was more like a bubble than a cone. Weird. I replaced gasket as well- Changed radiator today. Seems to have done the trick. must have been a small leak. THX!
 

·
Super Moderator
Joined
·
12,635 Posts
The thermostat doesn't go into the intake manifold... Sounds like the radiator might have been clogged up keeping the coolant from circulating the way it should.
 
1 - 5 of 5 Posts
Top