Hyundai Elantra Forum banner

1 - 16 of 16 Posts

·
Banned
Joined
·
4,074 Posts
Discussion Starter · #1 ·
Ok heres my problem guys,when I first start my car and its not warm and I put it in drive and accelerate im getting a little hesatation..Could it be bad gas? Or maybe my fuel injectors need to be cleaned?..Should I buy a bottle of that fuel injector cleaner? or even put a tank of prem gas in?
 

·
Registered
Joined
·
1,790 Posts
Premium gas rarely ever helps as our cars only really need the lowest octane to perform properly. What does it do when it's warmed up?? Don't gun a cold engine is the rule.
 

·
Registered
Joined
·
291 Posts
I fill up with a tank of premium and add a bottle of injector cleaner everytime I change the oil just to keep eveything squeaky clean. Not sure if it does anything but I figure it can't hurt, and if you add the cost of the cleaner and premium it's just a few bucks. Part of the reason I do it is the dealership has already replaced my plugs once (at 7K miles) as they were fouled.
 

·
Registered
Joined
·
192 Posts
Silverbullet, my car does the same thing. When it has been sitting for a bit, it hesitates when I start and then is ok. I am taking my car into the dealer to have an airbag sensor changed on monday and they are gonna check on this problem also. I'll let you know what I find out after they look at it. They suggested bad gas too but I have been using the same brand of gas for a couple months and the hesitation just started in like the last week or so.
 

·
Banned
Joined
·
4,074 Posts
Discussion Starter · #5 ·
When I let it warm up its fine but when I start it and then right away drive it happens....Im gonna try a fuel injector/gas treatment and ill let you guys know what happens.
 

·
Registered
Joined
·
281 Posts
You might also want to get your battery tested. It might be lossing its charge over night. I see you have an upgraded radio. If you still running your oem battery I put my money on if you replace it, it will go away.
 

·
Premium Member
Joined
·
15,223 Posts
I've got the same thing, I only seem to notice it when I pull out of the work parking lot at the end of the day. Slight hesitation until I get to the second gear (auto trans) then it doesn't happen again. I consider it normal cold engine behavior.
 

·
Registered
Joined
·
1,790 Posts
hyunelan2 said:
I consider it normal cold engine behavior.
I think it's that too, because you only have symptoms when you start and drive off right away. Just show it some love and don't throw it into drive the next second after you start the car. Get in and turn the key, then close the door, get comfy, find your :cool: and search for a good song on the radio or your CD, that's sometimes enough time for me to waste for the car to be ready, cause I don't like sitting there twiddling my thumbs either, but your car will thank you for those first 15 or so seconds.
 

·
Registered
Joined
·
281 Posts
Won't hurt to have it checked. Auto zone will test for free just take it in. I don't know if you have an auto or not. But if you do check the fluids make sure they are good. Also a battery reset never hurts anything. I have an auto 03gt sedan with 22k on it and dosn't have the problem you are talking about. But something has happend 3 times that I can remember. If i would sit at a light or a stop and put the car in park. Then put the car into drive to fast then get in the gas not alot but enough to get moving the car would stall. plugs and terrminals all good? if you did the hyper ground wire mod everything still tight and connected with that?

XDGT03 said:
also, for the long term health, do the pcv bypass mod
I have yet to see one car last longer with this mod. It's something people do for peace of mind or something but isn't needed. Then if its done wrong it can cause alot more damage then any gain it may give. I personaly think the pcv bypass is about as cool as listing mobil1 as a mod to your car.
 

·
Banned
Joined
·
11,228 Posts
There's a TSB out here on this issue. It covers the stumbling as well as the 3800-4000RPM bog. I'm looking for it now . . . . (man I hate our new dial up connection!). . . . and looking. . . . . here it is: 04-36-004.

It covers 01-03 Elantra's for cold start stumbles and the infamous bog.
They basically do a reflash of the ecm with updated programs. Some dealers don't have this program but they should be able to fix it.
 

·
Registered
Joined
·
11 Posts
i had the same problem it was my throttle body sensor, it started out like that and just got worst from there, try that see what happens oh and its a warrenty problem
 

·
Registered
Joined
·
16 Posts
I agree. Dont let it go to long. I did and am having a terrible time finding the real problem. Ive changed my sparkplugs and wires three times in three months (because of dealer suggestion) and the car still isnt as peppy as it use to be.
 

·
Banned
Joined
·
4,074 Posts
Discussion Starter · #16 ·
Ok it has not happend since I switched from useing a cheap gas station and started useing Hess again..By the way the only reason I was useing a cheap gas station is becuase gas on Long Island,NY is $2.05 gallon for REG.
 
1 - 16 of 16 Posts
Top