Hyundai Elantra Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
Hello XD owners,
I installed the tiburon swaybar upgrade today with poly bushings and moog metal endlinks. When installing the bar is hitting the frame and rubbing against the gas filler tube. I just went ahead and installed it anyway hoping it would clear once the car is on the ground. When I drive it it clunks over bumps. Does it take time to self clearance or did I install it wrong. I matched the bends to the stock swaybar and pretty sure its on the correct way. Not sure if anyone else has encountered this issue.

EDIT: Installed swaybar the wrong way, see the video I made to avoid this issue and install it correctly!
 

· Registered
Joined
·
1,898 Posts
Hello XD owners,
I installed the tiburon swaybar upgrade today with poly bushings and moog metal endlinks. When installing the bar is hitting the frame and rubbing against the gas filler tube. I just went ahead and installed it anyway hoping it would clear once the car is on the ground. When I drive it it clunks over bumps. Does it take time to self clearance or did I install it wrong. I matched the bends to the stock swaybar and pretty sure its on the correct way. Not sure if anyone else has encountered this issue.

I installed two in my cars. One yellow dot, one green dot. I didn't have any issues with either. It cleared easily. I don't know why it would be hitting anything. You probably have it backwards.
 

· Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
Never updated this thread, but it was installed backwards, no idea what was going through my head but I flipped it and it worked. I posted a video with the full install and showed this error in the vid so people know what it looks like if the swaybar is backwards. Thanks guys!
 
1 - 4 of 4 Posts
Top