Hyundai Elantra Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
988 Posts
Discussion Starter · #1 · (Edited)
1. I have just replaced timing belt and installed water pump pulleys before installing lower timing belt cover because I have more room to work. Now I cannot install the lower timing belt cover because water pump pulleys are blocking. It looks like I have to remove water pump pulleys and start all over. How critical is the timing belt cover? Can I drive without the lower timing belt cover temporarily ( for about a week)? I have to go to work and I don't have time to do it over now.

2. I need to replace the A/C belt, but I cannot adjust the belt tension. The adjusting bolt is stuck. Any idea?

3. Finally, I also need to install water pump- alternator belt, but I cannot install it. It looks like the new belt is a little small. I compared with the old belt, but it looks like same size. I loosend the alternator tension to the maximum, but still I cannot install it. What do I need to check? I did these things three years ago when I changed my timing belt and I didn't have problem at that time. I forgot what I need to check. I would appreciate any advice greatly.

P.S. One more question. My new timing belt doesn't have arrows. Old timing belt has arrows: that means it's directional. The belts are both Gates belts. Did they change the belt style? Did they change the timing belt to non-directional?
 

·
turbo envy
Joined
·
12,884 Posts
1. you have to put the cover back on....and you have to do it while everything is off....you will have to take everything off and put it on....yes its that important.

2. get a new tensioner or go without ac

3. you need to loosen the 12 mm nut on the bottom side of the alt...then push it as far as you can toward the motor...you can use a long screw driver or pry bar.

4. the belt should be directional.

I just literally got done with my wifes 04 125k service which included timing belt, h2o pump, and thermostat. Looks like i need to do the valve cover and plugs as well.
 

·
Registered
Joined
·
988 Posts
Discussion Starter · #3 · (Edited)
Water pump pulleys have been reinstalled and the lower timing belt cover also has been installed. The last remaining problem is alternator-water pump belt. I have no idea why I can't install it. I double, triple checked the belt size and it was correct size.
 

·
turbo envy
Joined
·
12,884 Posts
again...did you loosen the nut underneath the alt?? the new belt is going to be the same size yes...but its going to be a much tighter fit. The old belt is going to have lots of give.
 

·
Registered
Joined
·
988 Posts
Discussion Starter · #7 · (Edited)
Thanks only1db. I loosened the 12 mm nut at the bottom of the alternator, but maybe not enough. The alternator swings to the back when I push, but not completely. It stops at half way of the adjusting slot. I will try again tomorrow because it began to rain this afternoon. In the instruction sheet of the Gates timing belt, it didn't mention the direction of the belt. I have kept the old timing belt, and it shows five parallel arrows in every foot on the belt: that means the belt is directional. New belt doesn't have such image at all. But the instruction sheet states that if the belt is reused, it should follow the direction of rotation marking.

One more question: When you changed the water pump, did you change the O ring inside the inlet pipe? It is supposed to do according to the shop manual. I had the water pump changed last time at the dealer. When I removed the water pump this time , there was no O ring. I inserted a new O ring anyway. It was surprising that it didn't leak even though they forgot it.

Last time when I had my timing belt replaced at the dealer, they stripped the timing belt cover gaskets away because installing especially the lower timing belt cover with gasket is pain. The oil leak from the valve cover ran down to inside the timing belt covers and the grooves were full of oil. I was lucky that the oil didn't contaminate the belt yet.

It looks like the square bolt at the other bottom side of the alternator may be blocking the alternator from further moving. Nothing else is blocking. Do I need to loosen the square bolt?
 

·
turbo envy
Joined
·
12,884 Posts
nope...just the nut...it squeezes down on the alum to hold it firmly into place.

There is no o ring...just the water pump gasket.

The gaskets on the covers are pitas and can break very eaily. I did an older tib when i was at the dealership and they pretty much just crumbled in my hands (florida is not very dgood for rubber parts)...the girls parent was an engineer and wanted all of them replaced...it was complete crap...they are there yes...but its more of a sound deadening then anything else...so if they are missing its not the end of the world.

I should have taken a video of my doing the timing belt...maybe when i do my 03 i will take a video. haha I make it look easy. LOL i guess thats what happens after the 100th one uh?
 

·
Registered
Joined
·
988 Posts
Discussion Starter · #9 · (Edited)
Automotive tire Organism Motor vehicle Automotive exterior Bumper I thought that the square bolt at the bottom of the alternator may be the problem, but I will try again tomorrow afternoon and keep you updated.

According to the Hyundai service website and Chilton's manual, new O ring is required to be inserted at the end of the inlet pipe right behind the water pump during water pump replacement procedure. However, O ring may not be a critical factor if you have good seal in the water pump gasket. I know the importance of the O ring when I tried to repair leaking kitchen faucet. Simple O ring replacement stopped water leak.

My lower timing belt cover was cracked while I tried to put it back during my last belt change. I was able to glue it and reused. It is much easier to insert the lower timing belt cover without the rubber gasket because there is more leeway. That's why the dealer stripped away the gaskets.
If you look at the shape of the cover, it has top, neck and the trunk. The top is much wider than the neck. You must push it up through the narrow opening between the motor mount and the water pump. Normally, the top cannot pass through the area without tweaking it: just squeeze the top in and force it to slip through the bottleneck. The timing belt cover is flexible to some extent, but not a lot. Be careful not to break it. I was able to attach new rubber gasket into the grooves with sealant and install it successfully. (Or, you can simply remove the motor mount on the engine block. It will be much easier to install the lower timing cover, but it takes extra half an hour to do that.)
 

·
Registered
Joined
·
988 Posts
Discussion Starter · #11 · (Edited)
I just checked the alternator again. It swings back when I pull up, but it stops at half way on the adjusting slot. I looked at where it stops, and I found out that the alternator casing hits the interior water pump pulley (which is connected to power steering pulley through a belt. The power steering belt was properly installed already). After I removed the alternator bracket for the water pump change, I re-installed it. Two bolts in the back of the bracket go through the water pump housing and to the engine block. Two bolts on the top of the bracket are attached to the power steering pump bracket. The alternator should not touch the water pump pulley, right? Could you please tell me if something is wrong with my alternator bracket installation? I think that is the only possible remaining problem to install the belt back on.
 

·
turbo envy
Joined
·
12,884 Posts
the bolts should just go back in and there should be no problem...can you take a pic or better yet have a vid? If i wasnt working 24/7 i would go out and take my own vid. haha
 

·
Registered
Joined
·
988 Posts
Discussion Starter · #13 ·
O.K. I will post pics or video tomorrow morning. By the way, does your alternator move all the way to the top end of the adjusting slot? I believe it should be like that, but mine doesn't. I don't know why it stops halfway.
 

·
Registered
Joined
·
988 Posts
Discussion Starter · #14 · (Edited)
I think I found what the problem is: the alternator bracket was slightly misaligned by a few mm. I had a trouble to install the alternator bolt A. The bolt A goes trough the adjusting slot and I couldn't put the bolt back in. While I was videotaping the trouble area this morning to post, I discovered the problem. I loosened the four bolts ( two to water pump and two to power steering bracket) and aligned the adjusting slot of the alternator bracket and tightened again, then it works fine now. Problem solved! I am going to mount the alternator-water pump belt tomorrow and finish the timing belt job. I will keep you updated after I finish the job. Thanks.

I just mounted the alternator-water pump belt and adjusted the tension. I reconnected the battery and turn on the ignition.
Voila! It was good, but a little rattling noise from the timing belt cover area. It's not bad, but a little dull noise, maybe timing belt is hitting the cover. It looks like a blower noise from the furnace in my basement. It's not high pitch whirling noise. I might need to adjust the timing belt tension.
I set the tensioner key hole to 11 o'clock position as I did in the past. I discovered this knowhow from a Korean Automotive College website before. The web page disappeared since then. I remember you once said that the key hole should be set at 5:30 or 6 o'clock position. I didn't know this knowhow when I changed my timing belt last time. The tension of the timing belt was so high that it made loud whirling and rattling noise. I kept driving for almost three weeks with this noise. After I adjusted the tensioner key hole to 11 o'clock position, the noise immediately disappeared. Since then I drove more than 90,000 miles. I inspected the old timing belt and it looked pretty good. I could've driven maybe 10,000 miles more, but I didn't want any risks. Since I drove for three weeks with high tension timing belt, I thought it may have shortened the life of the belt.
Any reliable information about setting the tensioner keyhole should be greatly appreciated.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top