Hyundai Elantra Forum banner

Status
Not open for further replies.
1 - 15 of 15 Posts

·
Registered
Joined
·
1,115 Posts
Discussion Starter #1
Hey all!,

I bought a Walbro 255LPH EVO8 Pump and installed it into my BetaII Turbo Tiburon yesterday. Install was fairly easy but time consuming as I had to do a couple of trial fits to get it to work right. You see the new pump is about 1/4 inch longer than the old pump. I also had to use the filter screen that came with the pump instead of the Hyundai part. Other than that, its in and working.
Now here's what I'm seeing. The BetaII fuel systems have a Fuel Pressure regulator in the fuel pump assembly. This is a propietary item and cannot be upgraded. It's designed to push 49.5psi at idle with the ECU slightly increasing voltage to the pump at WOT. There is not a pressure switch anywhere in the fuel system that tells the ECU what is the current fuel pressure like I originally thought. Also the fuel pump connector is a standard two pin connector and it plugs right into the Walbro fuel pump.
So what happened when I installed it and started the car? My idle PSI is now at 80PSI due to the high volume pump overwhelming the OEM FPR. At first I was like "Oh crap!", but then I realized the car was running fine. Aparently the OEM ECU was able to cut the Injector pulse width down enough so even at 80PSI idle was unaffected.
So after that I decided to make some quick high boost runs around the block to see what happened (I know, I'm crazy like that). Guess what? Due to the high volume pump I run super mega rich at WOT!! This at 15PSI boost!!
I was at +10 on the SAFC with at 11.8:1 A/F Ratio before the install. After? All I know is according to my Wideband meter I was 'RICH'. Which means it was below 10.1:1!!! So I went down to -10 on the AFC and now am at a rock solid 10.5:1 ratio. I know its still rich, but I ran out of time yesterday. I plan on going to the track today for some more tuning.

Sorry for the long post but I felt this was news worthy..
 

·
Registered
Joined
·
454 Posts
so are you going to test the limits of the stock internals? what are you at now 240 something to the wheels? Keep us updated
 

·
Registered
Joined
·
499 Posts
That's good stuff! Thanks for letting us know!
Why did you decide to upgrade the pump? Did you feel like it was maxed out at 240whp?
 

·
Registered
Joined
·
1,115 Posts
Discussion Starter #4
I upgraded mainly because I wasn't sure what the OEM pump would max out at. I hope the Walbro can last running at 80psi, otherwise I will have to through the OEM back in with maybe a Boost-a-pump or something.
 

·
Registered
Joined
·
1,270 Posts
Just be carefull going that high with boost with stock internals, supposedly around 6-8 psi is the limit (and oviously it can be more, just for liability reasons they say these numbers) but my buddy had turbocharged his car and got it up to 14 psi, and it worked perfectly up till when he turned it up a little more, and at 14 psi he blew his piston rings. Maybe you should look into some forged pistons, such as the ones that tigerlilly make, then you could prpbably even turn your boost up a little bit higher.
 

·
Registered
Joined
·
3,151 Posts
I think that with low compression built pistons he should be fine... The compression on the pistons is really the most dangerous aspect of major boost. So if you installed low comp pistons, say 9.xx:1 you should be able to boost past 12-13 psi.

shawn
 

·
Registered
Joined
·
1,115 Posts
Discussion Starter #10
Actually with the Alpine Turbo kit in includes a head space that lowers the effective CR to 8.5:1. Nice and Turbo safe...

Oh, and the nice new pistons will be going into my engine project sitting on the garage floor... :)

So far the car is holding up really well. I went to the track yesterday and pounded on it for hours with no problem whatsoever... :D
 

·
Registered
Joined
·
741 Posts
My ROSS pistons should be here soon. Im replacing the whole fuel system so i have my own regulator, but its nice to know that the pump goes in with out too much fuss.
 

·
Carpe Noctum
Joined
·
2,462 Posts
Maybe should have asked 4 years ago?
 
1 - 15 of 15 Posts
Status
Not open for further replies.
Top