Hyundai Elantra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Hi guys,

4 Months ago I rear ended a car. The car was still driveable, just had a slight vibration feeling to it. Anway I was overseas for 3 months so when I got back the damage was repaired, and just recieved it yesterday. The damage was mainly to the rain and bumper bar (head on). Anyway, after driving it yesterday and today there is still that vibration feeling.

Does anyone know what could have happened? Could the gearbox have shifted a little bit, causing the vibration feeling? Could the CV joints have anything to do with it? The alignment seems fine, as it goes in a straight line when I let go of the wheel. The vibration is noticible in the brake pedals and the steering wheel even when idle. And going highway speeds is fine, but it amost feels as if it is struggleing a bit.. So yea any ideas what could've gone wrong? Besides that the car is driving fine, I have pushed it hard and nothing wrong.. In 2 weeks hopefully I can get a friend to have a look at the car but not sure yet :( I have already spent heaps on this car and it has to last me couple more years now because of this crash :p So yea any ideas people :)

Thanks,

Anthony

Elantra 2004 GLS
 

·
Registered
Joined
·
6 Posts
I would go see if the alignment is off. The car would probably still go strait even if just the back is off. Many shops check it for free.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
I know the alignment is off as when im on the highway it vibrates. I will be doing an alignment soon. The vibration I am talking about is there during idle. I had a quick look and it appears the motor mount holding the tranmission (right hand side when looking from the front) looks cracked. I am still waiting for a mechanic friend to take a look at it but pretty sure its that mount..

Would a cracked mount make a noticible vibration? the other 3 mounts are fine. The cost to repair this mount is 350$ for the part (Australia.. OEM) or 150$ for aftermarket part.. and 88$ in labour.

Should I go OEM or after market? I am in australia and everything is expensive here lol. attached is picture.. 2011-03-05 06.37.06.jpg

What do you guys think?
 

·
Registered
Joined
·
1,579 Posts
Can't tell the condition of the mount from the picture. But a bad mount would be the cause of idle vibration. Also I would check the balance of your tires too. Also check plugs/wires, etc for performance related issues which make be causing a rougher idle.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
Hey,

Well I took out the airbox to have a better look at the mount. Yea its completly ****ed through! I gave Hyundai another call yesterday (different one) and they quoted 135$ for parts and 88$.. so I am going to replace and see :D Everything else should be fine (plugs/wire) car is only at 68000 but i shall see what happens after the mount + alignment.

Thanks :)
 
1 - 5 of 5 Posts
Top